Bug #349

Syncrepl provider not working with v2.4.26

Added by Nick Milas almost 3 years ago. Updated almost 3 years ago.

Status:Rejected Start:17/10/2011
Priority:Normal Due date:
Assigned to:Clément OUDOT % Done:

100%

Category:OpenLDAP RPM
Target version:-

Description

Hello,

I have tried to migrate my current 2.4.22 to LTB 2.4.26 (as an RPM). This is a syncrepl provider server.

However, while everything works fine, syncrepl provider doesn't seem to work. All consumers do not receive data from the provider.

Here is my configuration:

overlay syncprov
syncprov-checkpoint 100 10
syncprov-sessionlog 100

Do I need a special module to be loaded? On consumers (using LTB) I don't use any additional module. The above configuration works fine with my 2.4.22 (with syncprov.la module), but no additional module was needed in LTB-based consumers.

Please advise.

Thanks,
Nick

History

Updated by Clément OUDOT almost 3 years ago

LTB packaging do not ship overlays as modules, they are built in slapd.

Check maybe your SSL configuration.

Updated by Nick Milas almost 3 years ago

Thanks, I thought so.

The problem is it didn't work without SSL either! Message:

LDAP_RES_SEARCH_RESULT (53) Server is unwilling to perform

The configuration is identical to the one I used for v2.4.22.

Nick

Updated by Clément OUDOT almost 3 years ago

Hi Nick,

this seems to be more an OpenLDAP question... Try maybe to ask on openldap technical mailing list, providing debug logs.

Updated by Nick Milas almost 3 years ago

  • Status changed from New to Closed

After I did a fresh slapcat (from version 2.4.22 which was in use as a provider) and a fresh slapadd (to new LTB 2.4.26 CentOS RPM) of the whole DIT and restarted, surprise!, everything worked like a breeze.

Can't tell what was the source of the problem, but it obviously was not related to LTB.

Thanks,
Nick

Updated by Clément OUDOT almost 3 years ago

  • Target version changed from openldap-rpm-? to openldap-rpm-2.4.27

Updated by Clément OUDOT almost 3 years ago

  • Status changed from Closed to Rejected
  • Assigned to set to Clément OUDOT
  • Target version deleted (openldap-rpm-2.4.27)
  • % Done changed from 0 to 100

Also available in: Atom PDF